From 9455f9b85f7184119b7eeccc7574c0a6d1035e43 Mon Sep 17 00:00:00 2001 From: JeanExtreme002 Date: Fri, 9 Oct 2026 12:17:47 -0300 Subject: [PATCH] fix(nodejs): bump undici floor to 6.29.0 to clear high-severity audit The scheduled Node.js Package run fails at the enforced npm audit step because undici 6.28.0 is affected by GHSA-3wwx-pv8p-q78v, GHSA-r53p-7pc4-xj5r and GHSA-rfgv-xxqx-mfg5. All three are fixed in 6.28.1+, and 6.29.0 still supports Node >=18.17, so the engines range and the 18.x matrix leg are unchanged. --- nodejs/package-lock.json | 8 ++++---- nodejs/package.json | 2 +- 2 files changed, 5 insertions(+), 5 deletions(-) diff --git a/nodejs/package-lock.json b/nodejs/package-lock.json index 2e17712..cc6696d 100644 --- a/nodejs/package-lock.json +++ b/nodejs/package-lock.json @@ -10,7 +10,7 @@ "license": "MIT", "dependencies": { "node-html-parser": "^6.1.13", - "undici": "^6.28.0" + "undici": "^6.29.0" }, "devDependencies": { "chai": "^4.3.10", @@ -2964,9 +2964,9 @@ } }, "node_modules/undici": { - "version": "6.28.0", - "resolved": "https://registry.npmjs.org/undici/-/undici-6.28.0.tgz", - "integrity": "sha512-LIY910g9TI13YS95lrMFrs8Rm/u/irgHeTWoKCoteeJ04CUJ92eEfj0rVn+7VKMPBpUPiUoBKfhNyLI23EE/KA==", + "version": "6.29.0", + "resolved": "https://registry.npmjs.org/undici/-/undici-6.29.0.tgz", + "integrity": "sha512-R+RODBqp6i2pPflGdq+xIOUkl+RNfGgHwoinecKu/JCuf2uO06cOKoDbI2P7Dn6KcswdKwrczbU6IYJ6K8X+wg==", "license": "MIT", "engines": { "node": ">=18.17" diff --git a/nodejs/package.json b/nodejs/package.json index eb8d50b..1724547 100644 --- a/nodejs/package.json +++ b/nodejs/package.json @@ -36,7 +36,7 @@ }, "dependencies": { "node-html-parser": "^6.1.13", - "undici": "^6.28.0" + "undici": "^6.29.0" }, "devDependencies": { "chai": "^4.3.10",