Repository navigation
fix: Bump Go toolchain to 1.27.3 for crypto/x509 vulnerability - #1418
Merged
Merged
Conversation
Resolves govulncheck alert GO-2026-6809 (distrust compromised intermediate certificates in crypto/x509), fixed in go1.27.3. go.mod moves its floor to 1.27.3 so GOTOOLCHAIN=local on an older 1.27 fails; ci-tools/go.mod's toolchain hint follows. Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
Deploying genealogix with
|
| Latest commit: |
3a1aad3
|
| Status: | ✅ Deploy successful! |
| Preview URL: | https://15141a41.genealogix.pages.dev |
| Branch Preview URL: | https://fix-go-1-27-3-x509.genealogix.pages.dev |
Codecov Report✅ All modified and coverable lines are covered by tests. 📢 Thoughts on this report? Let us know! |
noahbjohnson
approved these changes
Oct 27, 2026
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Resolves code scanning alert #269:
GO-2026-6809, Distrust compromised intermediate certificates incrypto/x509, fixed in Go 1.27.3.Changes
go.mod:go 1.27.2→go 1.27.3. This keeps the floor convention from chore: Move to maintained YAML module and tighten go.mod floor #1407, so aGOTOOLCHAIN=localbuild on an older 1.27 fails instead of quietly using the unpatched standard library.ci-tools/go.mod:toolchain go1.27.2→toolchain go1.27.3.No workflow edits are needed: every
setup-gostep readsgo-version-file: go.mod.Verification (local, go1.27.3)
go build ./...,go vet ./...andgo test ./...all pass.go mod tidy -diffis clean for both modules.govulncheck ./...now reports 0 vulnerabilities in imported packages (it reportedcrypto/x509before). The one remaining module-level finding isGO-2026-5932(x/crypto/openpgp, no fix available, not imported). It was already there and is unrelated to this change.Downstream importers of
go-glxwill need Go 1.27.3+.🤖 Generated with Claude Code